Model Override Problem

I am having an issue where my model is not overriding when I try to upload an updated version. Instead, it is just adding a new model with the same name. I double checked all of my naming conventions and nodes and they seem to be identical so I’m not sure why this is happening. I built the model in blender and have been importing it as an .fbx file to Threekit. I also submitted a case to the support page but haven’t heard back. Does anyone see a fix to this that I am missing? Or should I just assume its broken and start using my new model?

These are the nodes in the model that is not overriding

These are the nodes for the updated model

Thank you for submitting a case. If you are uploading an asset with the same name into a the same folder, it should be overriding.

You can try explicitly doing the asset merge from the editor. If you open the editor and CTRL + select + drag the asset into the main scene, it will override it there also.


That worked! Thank you!

Thanks Nicole! @JuliaK68 I can confirm your case was logged and our team is looking into it. You should have received an email generated when the case status was updated.

Yep, thanks Will! I received an update that it was escalated to the engineer team on Oct. 1 but haven’t heard anything since.

When a case is confirmed to be a bug the product team prioritizes it and it ultimately gets put into one of the updates on our regular schedule. Unfortunately there’s not always a way to tell when the fixes will be deployed.

In the meantime while the bug is being investigated, I hope the steps Nicole gave you above are helpful!

1 Like

No problem! The workaround Nicole gave me worked like a charm! Thanks so much for the help and quick responses :star_struck: